import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(....AA........CC............BB..)";
final String string = "215484320702AAFF155777CCFF9101101132BB4E00A0AACCCCCCCCCCCCCCF0111009BB850702AAFF155777CCFF9101101010BBXX\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}