re = /(....AA........CC............BB..)/
str = '215484320702AAFF155777CCFF9101101132BB4E00A0AACCCCCCCCCCCCCCF0111009BB850702AAFF155777CCFF9101101010BBXX
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end