// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(....AA........CC............BB..)").unwrap();
let string = "215484320702AAFF155777CCFF9101101132BB4E00A0AACCCCCCCCCCCCCCF0111009BB850702AAFF155777CCFF9101101010BBXX
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}