# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?![\+\-\*\\/\(\)\^\s])([a-zA-Z0-9]+)\^([a-zA-Z0-9]+)/pow($1,$2)/gm;t' <<< "w*x^2 +5^9"