import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?![\\+\\-\\*\\/\\(\\)\\^\\s])([a-zA-Z0-9]+)\\^([a-zA-Z0-9]+)";
final String string = "w*x^2 +5^9";
final String subst = "pow($1,$2)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}