import Foundation
let pattern = #"(?![\+\-\*\/\(\)\^\s])([a-zA-Z0-9]+)\^([a-zA-Z0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"w*x^2 +5^9"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"pow($1,$2)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)