re = /(?![\+\-\*\/\(\)\^\s])([a-zA-Z0-9]+)\^([a-zA-Z0-9]+)/m
str = 'w*x^2 +5^9'
subst = 'pow($1,$2)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result