const regex = /(?![\+\-\*\/\(\)\^\s])([a-zA-Z0-9]+)\^([a-zA-Z0-9]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?![\\+\\-\\*\\\/\\(\\)\\^\\s])([a-zA-Z0-9]+)\\^([a-zA-Z0-9]+)', 'gm')
const str = `w*x^2 +5^9`;
const subst = `pow($1,$2)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);