use strict;
my $str = 'w*x^2 +5^9';
my $regex = qr/(?![\+\-\*\/\(\)\^\s])([a-zA-Z0-9]+)\^([a-zA-Z0-9]+)/mp;
my $subst = 'pow($1,$2)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";