$re = '/(?![\+\-\*\/\(\)\^\s])([a-zA-Z0-9]+)\^([a-zA-Z0-9]+)/m';
$str = 'w*x^2 +5^9';
$subst = "pow($1,$2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;