#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:(?<!\w)'((?:.|\n)+?'?)(?:(?<!s)'(?!\w)|(?<=s)'(?!([^']|\w'\w)+'(?!\w))))"
Local $sString = "'The Joneses' car'. Similar to the 'Kumbh melas', celebrated by the banks of the holy rivers of India. 'Hey'! you'll, I'm, he's, " & @CRLF & _
"some random text 'what if it's" & @CRLF & _
"multiline?'. 'I'm one of the persons''" & @CRLF & _
"" & @CRLF & _
"'the classes' hours'" & @CRLF & _
"" & @CRLF & _
"'the Joneses' car' guys' night out" & @CRLF & _
"'two actresses' " & @CRLF & _
"roles' and 'the hours' of classes'" & @CRLF & _
"" & @CRLF & _
"'The Joneses' car won't start'"
Local $sSubst = ""\1""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)