const regex = /(?:(?<!\w)'((?:.|\n)+?'?)(?:(?<!s)'(?!\w)|(?<=s)'(?!([^']|\w'\w)+'(?!\w))))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?<!\\w)\'((?:.|\\n)+?\'?)(?:(?<!s)\'(?!\\w)|(?<=s)\'(?!([^\']|\\w\'\\w)+\'(?!\\w))))', 'g')
const str = `'The Joneses' car'. Similar to the 'Kumbh melas', celebrated by the banks of the holy rivers of India. 'Hey'! you'll, I'm, he's,
some random text 'what if it's
multiline?'. 'I'm one of the persons''
'the classes' hours'
'the Joneses' car' guys' night out
'two actresses'
roles' and 'the hours' of classes'
'The Joneses' car won't start'`;
const subst = `"\1"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);