re = /(?:(?<!\w)'((?:.|\n)+?'?)(?:(?<!s)'(?!\w)|(?<=s)'(?!([^']|\w'\w)+'(?!\w))))/
str = '\'The Joneses\' car\'. Similar to the \'Kumbh melas\', celebrated by the banks of the holy rivers of India. \'Hey\'! you\'ll, I\'m, he\'s,
some random text \'what if it\'s
multiline?\'. \'I\'m one of the persons\'\'
\'the classes\' hours\'
\'the Joneses\' car\' guys\' night out
\'two actresses\'
roles\' and \'the hours\' of classes\'
\'The Joneses\' car won\'t start\''
subst = '"\\1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result