import Foundation
let pattern = #"(?:(?<!\w)'((?:.|\n)+?'?)(?:(?<!s)'(?!\w)|(?<=s)'(?!([^']|\w'\w)+'(?!\w))))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
'The Joneses' car'. Similar to the 'Kumbh melas', celebrated by the banks of the holy rivers of India. 'Hey'! you'll, I'm, he's,
some random text 'what if it's
multiline?'. 'I'm one of the persons''
'the classes' hours'
'the Joneses' car' guys' night out
'two actresses'
roles' and 'the hours' of classes'
'The Joneses' car won't start'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""\1""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)