import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<!\\w)'((?:.|\\n)+?'?)(?:(?<!s)'(?!\\w)|(?<=s)'(?!([^']|\\w'\\w)+'(?!\\w))))";
final String string = "'The Joneses' car'. Similar to the 'Kumbh melas', celebrated by the banks of the holy rivers of India. 'Hey'! you'll, I'm, he's, \n"
+ "some random text 'what if it's\n"
+ "multiline?'. 'I'm one of the persons''\n\n"
+ "'the classes' hours'\n\n"
+ "'the Joneses' car' guys' night out\n"
+ "'two actresses' \n"
+ "roles' and 'the hours' of classes'\n\n"
+ "'The Joneses' car won't start'";
final String subst = "\"\\1\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}