using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<!\w)'((?:.|\n)+?'?)(?:(?<!s)'(?!\w)|(?<=s)'(?!([^']|\w'\w)+'(?!\w))))";
string substitution = @"""\1""";
string input = @"'The Joneses' car'. Similar to the 'Kumbh melas', celebrated by the banks of the holy rivers of India. 'Hey'! you'll, I'm, he's,
some random text 'what if it's
multiline?'. 'I'm one of the persons''
'the classes' hours'
'the Joneses' car' guys' night out
'two actresses'
roles' and 'the hours' of classes'
'The Joneses' car won't start'";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}