const regex = /([\pL\pM _()$&"'0-9\/!@^=+*-])+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\pL\\pM _()$&"\'0-9\\\/!@^=+*-])+', '')
const str = `こ ん に ち はLkbnfbj"dsfdfdsfdsd48446こ んfds您好/!@^=+dsd"--હે લોLsfsPNOPpdsd"Hi"Hallåfdfsdf fdsfsdfdsfdfddcgd こ-ん-に-ち-は હેલો হ্যালো Салом வணக்கம் สวัสดี Olá Hallåनमस्ते'''''dsdd*sdd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}