// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"([\pL\pM _()$&"'0-9\/!@^=+*-])+"#).unwrap();
let string = "こ ん に ち はLkbnfbj\"dsfdfdsfdsd48446こ んfds您好/!@^=+dsd\"--હે લોLsfsPNOPpdsd\"Hi\"Hallåfdfsdf fdsfsdfdsfdfddcgd こ-ん-に-ち-は હેલો হ্যালো Салом வணக்கம் สวัสดี Olá Hallåनमस्ते'''''dsdd*sdd";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}