#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)<a\K|\G(?!^)[^>]*?\K'|<img\K|\G(?!^)[^>]*?\K'"
Local $sString = "<a href='fooo' >hai</a><img src='foo' >hai'b"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)