use strict;
my $str = '<a href='fooo' >hai</a><img src='foo' >hai'b';
my $regex = qr/<a\K|\G(?!^)[^>]*?\K'|<img\K|\G(?!^)[^>]*?\K'/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";