re = /<a\K|\G(?!^)[^>]*?\K'|<img\K|\G(?!^)[^>]*?\K'/mi
str = '<a href='fooo' >hai</a><img src='foo' >hai'b'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result