$re = '/<a\K|\G(?!^)[^>]*?\K'|<img\K|\G(?!^)[^>]*?\K'/mi';
$str = '<a href='fooo' >hai</a><img src='foo' >hai'b';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;