const regex = /<a\K|\G(?!^)[^>]*?\K'|<img\K|\G(?!^)[^>]*?\K'/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a\\K|\\G(?!^)[^>]*?\\K'|<img\\K|\\G(?!^)[^>]*?\\K'', 'gmi')
const str = `<a href='fooo' >hai</a><img src='foo' >hai'b`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);