# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?)ECTool(.*)//mg;t' <<< "https://www.bu2.knorr-bremse.com/ECTool/rgdfgddfg"