re = /(.*?)ECTool(.*)/m
str = 'https://www.bu2.knorr-bremse.com/ECTool/rgdfgddfg'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result