use strict;
my $str = 'https://www.bu2.knorr-bremse.com/ECTool/rgdfgddfg';
my $regex = qr/(.*?)ECTool(.*)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";