$re = '/(.*?)ECTool(.*)/m';
$str = 'https://www.bu2.knorr-bremse.com/ECTool/rgdfgddfg';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;