using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)ECTool(.*)";
string substitution = @"";
string input = @"https://www.bu2.knorr-bremse.com/ECTool/rgdfgddfg";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}