const regex = new RegExp('(.*?)ECTool(.*)', 'mg')
const str = `https://www.bu2.knorr-bremse.com/ECTool/rgdfgddfg`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);