# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*)\[([0-9]+).*?\](.*)$/$1$2$3/;t' <<< "db[3-4].abc.xyz.pqr.abc.abc.com"