using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*)\[([0-9]+).*?\](.*)$";
string substitution = @"$1$2$3";
string input = @"db[3-4].abc.xyz.pqr.abc.abc.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}