$re = '/^(.*)\[([0-9]+).*?\](.*)$/';
$str = 'db[3-4].abc.xyz.pqr.abc.abc.com';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;