const regex = /^(.*)\[([0-9]+).*?\](.*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)\\[([0-9]+).*?\\](.*)$', '')
const str = `db[3-4].abc.xyz.pqr.abc.abc.com`;
const subst = `$1$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);