// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(.*)\[([0-9]+).*?\](.*)$").unwrap();
let string = "db[3-4].abc.xyz.pqr.abc.abc.com";
let substitution = "$1$2$3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}