re = /^(.*)\[([0-9]+).*?\](.*)$/
str = 'db[3-4].abc.xyz.pqr.abc.abc.com'
subst = '$1$2$3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result