use strict;
my $str = 'db[3-4].abc.xyz.pqr.abc.abc.com';
my $regex = qr/^(.*)\[([0-9]+).*?\](.*)$/p;
my $subst = '$1$2$3';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";