#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=^|,)((\"[^\"]*\")|([^,]*))(?=$|,)"
Local $sString = "ec62c555,"6/22/2023, 4:02:54 PM","$250,000",no,"{""line"":""12345 ABC Street"",""line2"":"""",""city"":""Fremont"",""state"":""CA"",""zip"":""90000"",""country"":""United States"",""country_code"":""US""}",Email,Contracting Officer,no,1500,13-week,"{""label"":""Irving Inc."",""value"":""0011K00002S74Hr""}""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")