const regex = new RegExp('(?<=^|,)((\\"[^\\"]*\\")|([^,]*))(?=$|,)', 'g')
const str = `ec62c555,"6/22/2023, 4:02:54 PM","\$250,000",no,"{""line"":""12345 ABC Street"",""line2"":"""",""city"":""Fremont"",""state"":""CA"",""zip"":""90000"",""country"":""United States"",""country_code"":""US""}",Email,Contracting Officer,no,1500,13-week,"{""label"":""Irving Inc."",""value"":""0011K00002S74Hr""}"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}