import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^|,)((\\\"[^\\\"]*\\\")|([^,]*))(?=$|,)";
final String string = "ec62c555,\"6/22/2023, 4:02:54 PM\",\"$250,000\",no,\"{\"\"line\"\":\"\"12345 ABC Street\"\",\"\"line2\"\":\"\"\"\",\"\"city\"\":\"\"Fremont\"\",\"\"state\"\":\"\"CA\"\",\"\"zip\"\":\"\"90000\"\",\"\"country\"\":\"\"United States\"\",\"\"country_code\"\":\"\"US\"\"}\",Email,Contracting Officer,no,1500,13-week,\"{\"\"label\"\":\"\"Irving Inc.\"\",\"\"value\"\":\"\"0011K00002S74Hr\"\"}\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}