$re = '/(?<=^|,)((\"[^\"]*\")|([^,]*))(?=$|,)/';
$str = 'ec62c555,"6/22/2023, 4:02:54 PM","$250,000",no,"{""line"":""12345 ABC Street"",""line2"":"""",""city"":""Fremont"",""state"":""CA"",""zip"":""90000"",""country"":""United States"",""country_code"":""US""}",Email,Contracting Officer,no,1500,13-week,"{""label"":""Irving Inc."",""value"":""0011K00002S74Hr""}"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);