using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^|,)((\""[^\""]*\"")|([^,]*))(?=$|,)";
string input = @"ec62c555,""6/22/2023, 4:02:54 PM"",""$250,000"",no,""{""line"":""12345 ABC Street"",""line2"":"""",""city"":""Fremont"",""state"":""CA"",""zip"":""90000"",""country"":""United States"",""country_code"":""US""}"",Email,Contracting Officer,no,1500,13-week,""{""label"":""Irving Inc."",""value"":""0011K00002S74Hr""}""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}