use strict;
my $str = 'ec62c555,"6/22/2023, 4:02:54 PM","$250,000",no,"{""line"":""12345 ABC Street"",""line2"":"""",""city"":""Fremont"",""state"":""CA"",""zip"":""90000"",""country"":""United States"",""country_code"":""US""}",Email,Contracting Officer,no,1500,13-week,"{""label"":""Irving Inc."",""value"":""0011K00002S74Hr""}"';
my $regex = qr/(?<=^|,)((\"[^\"]*\")|([^,]*))(?=$|,)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}