import re
regex = re.compile(r"(?<=^|,)((\"[^\"]*\")|([^,]*))(?=$|,)")
test_str = "ec62c555,\"6/22/2023, 4:02:54 PM\",\"$250,000\",no,\"{\"\"line\"\":\"\"12345 ABC Street\"\",\"\"line2\"\":\"\"\"\",\"\"city\"\":\"\"Fremont\"\",\"\"state\"\":\"\"CA\"\",\"\"zip\"\":\"\"90000\"\",\"\"country\"\":\"\"United States\"\",\"\"country_code\"\":\"\"US\"\"}\",Email,Contracting Officer,no,1500,13-week,\"{\"\"label\"\":\"\"Irving Inc.\"\",\"\"value\"\":\"\"0011K00002S74Hr\"\"}\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")