# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+(\.\d+)?%//g;t' <<< "\"1234, Name of Entity, 29.5%, Germany\""