const regex = /\d+(\.\d+)?%/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(\\.\\d+)?%', 'g')
const str = `"1234, Name of Entity, 29.5%, Germany"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);