use strict;
my $str = '"1234, Name of Entity, 29.5%, Germany"';
my $regex = qr/\d+(\.\d+)?%/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";