import Foundation
let pattern = #"\d+(\.\d+)?%"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""1234, Name of Entity, 29.5%, Germany""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)