$re = '/\d+(\.\d+)?%/';
$str = '"1234, Name of Entity, 29.5%, Germany"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;