#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\d+(\.\d+)?%"
Local $sString = ""1234, Name of Entity, 29.5%, Germany""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)