re = /\d+(\.\d+)?%/
str = '"1234, Name of Entity, 29.5%, Germany"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result